[clug] Networking problem in Ubuntu Feisty

Francis Whittle fj.whittle at gmail.com
Tue Oct 9 05:51:08 GMT 2007


If you're using udev (highly likely with ubuntu), there's a possibility
that something has messed up during network device pinning.

You should have a file named something along the lines of
z??_persistent-net.rules in /etc/udev/rules.d ; Delete this file and
reboot (or stop udev, remove all network modules, and start udev again –
simply restarting it won't work).  You should then get persistently
named devices for all eth* if this is causing your problems
(furthermore, as you add network devices, they're made persistent in
this file).


On Tue, 2007-10-09 at 11:04 +1000, Mike Carden wrote:
> On 10/9/07, Robert Edwards <bob at cs.anu.edu.au> wrote:
> > It looks clear to me that Feisty, in all it's wisdom, has (re-)allocated
> > the RealTek card to eth0. Try unplugging your cable from your Intel port
> > (integrated?) and plugging it into the RealTek card and see if that
> > makes the problem go away.
> >
> I have tried booting with the cable in either port, and booting with
> the Realtek card removed and just the Intel onboard in place (where I
> started from really) but never do I get either interface working. I've
> tried booting then playing musical Ethernet cables, to no avail.
> And yet it 'just works' via a bootable CD.
> > Send us the output of /sbin/ifconfig -a as well - that will tell for
> > sure which interface is receiving packets from the network.
> I'll suss that out when I get home, thanks. I'd do it now from work,
> but I can't see the box because its network is no go. :-)  Chicken and
> egg problem.
> Maybe if I set up a video camera on the screen and some remote
> manipulators for the keyboard...
> Ta,
> MC

More information about the linux mailing list