[clug] Networking problem in Ubuntu Feisty

Mike Carden mike.carden at gmail.com
Mon Oct 8 10:35:46 GMT 2007

Sorry for the html email - I needed to highlight some console output.

My main desktop machine currently runs Ubuntu Feisty, and I can't get its
network up.

The main Ethernet connection is an Intel e100 integrated with the main board
and it worked under Dapper and previous OSes. On moving to Feisty it stopped
working. I thought at first that the Feisty version of the e100 driver was
corrupt, but manually installing a fresh kernel module didn't help.

I fitted a Realtek 8139 based card as well, but that hasn't helped.

If I boot to a live CD like Ubuntu Gutsy, the network comes straight up, so
I know the hardware works.

Here is the machine straight after booting in Feisty with a dead network:

mc at alloy:~$ lspci | grep Ethernet
02:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)

mc at alloy:~$ dmesg | grep Ethernet
[   28.715144] 8139cp: 10/100 PCI Ethernet driver v1.3 (Mar 22, 2004)
[    5.508000] 8139too Fast Ethernet driver 0.9.28

mc at alloy:~$ cat /var/log/messages | grep eth
Oct  8 20:06:05 alloy kernel: [    5.624000] eth0: RealTek RTL8139 at
0xd8850000,00:e0:4c:ef:12:aa, IRQ 11
Oct  8 20:06:05 alloy kernel: [    5.716000] e100: eth1: e100_probe: addr
0xe7001000, irq 10, MAC addr 00:01:80:05:25:4A

mc at alloy:~$ lsmod | grep 8139
8139too                27648  0
8139cp                 25088  0
mii                     6528  3 8139too,e100,8139cp

So as far as I can tell, it knows about the 8139 card and has loaded the
appropriate module. Here's what happens if I try to bring up eth0:

mc at alloy:~$ sudo dhclient eth0
There is already a pid file /var/run/dhclient.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFFLAGS: Resource temporarily unavailable
SIOCSIFFLAGS: Resource temporarily unavailable
Listening on LPF/eth0/00:01:80:05:25:4a
Sending on   LPF/eth0/00:01:80:05:25:4a
Sending on   Socket/fallback
receive_packet failed on eth0: Network is down
DHCPDISCOVER on eth0 to port 67 interval 3
send_packet: Network is down

Now, if I boot with a Gutsy Gibbon CD and the network is all okay, the lsmod
and lspci outputs look the same as they do under Feisty. I can start and
stop the network and dhclient works as expected. The only thing I can pick a
difference with is this:

ubuntu at ubuntu:~$ cat /var/log/messages | grep eth
Oct  8 09:52:10 ubuntu kernel: [    7.520000] e100: eth0: e100_probe: addr
0xe7001000, irq 10, MAC addr 00:01:80:05:25:4A
Oct  8 09:52:10 ubuntu kernel: [    7.608000] eth1: RealTek RTL8139 at
0xd884c000, 00:e0:4c:ef:12:aa, IRQ 11

It looks as though eth0 and eth1 have been swapped. And yes, I have tried
bringing up eth1 under Feisty and it tells me that it doesn't exist.

Any clues? My Googling has been ineffective and I still don't know what
'SIOCSIFFLAGS: Resource temporarily unavailable' means.


More information about the linux mailing list