[clug] LIVE PXE help

Chris u4123459 at anu.edu.au
Sun Jul 15 05:32:08 GMT 2007

Hi List,

I might have asked this before but the problem remains unsolved.

I am trying to boot a LIVE session (.e.g Ubuntu Live) using a network. 
The reasons for me personally is that I don't have to get a Cd-Rom and 
it is fast.

Installing a Linux system using PXE is not what I am after, I have done 
this a couple of times.

I have followed http://thomas.enix.org/pub/livecd/HOWTO-Ubuntu-Live-Speedup

I ran into some problems and emailed the author and it seemed like 
he/she probably couldn't figure out what went wrong.

The idea is to first install Grub on a USB key and use it to boot the 
client initially. On that same USB key copy across customized initrd.gz 
and vmlinuz files. This customized initrd.gz file has three additional 
parts comparing to a normal initrd.gz we copy off a Live CD. It has all 
the network card drivers taken from /lib/modules of the same kernel 
version. It also has a static dhcp client. (for this to work, one has to 
re-compile the dhcp client, Or simply download the sample initrd.gz 
supplied from the aforementioned website). Lastly it also needs NFS 
modules so that it can access a NFS server.

On an another computer, mount a Live CD image to a directory, and share 
that folder using NFS. Setup a dhcp server on this server and add

option nfs-ubuntu-livecd code 128 = text; option nfs-ubuntu-livecd 

So that once the client gets assigned an IP it knows what to do next. 
(to start Live session from a Live CD image, which is accessible at

The problem I was running into is that I had a 'file not found' error. 
This error occurred immediately after grub boot list selection and after 
initrd.gz was read. I think it is probably caused by the client unable 
to access the NFS share to continue booting from it.

I checked NFS share was working. And used WireShark to find out there 
was NO dhcp requests on the NFS server. This seems to suggest the image 
file on the USB key isn't working correctly. I downloaded the sample 
files just to make sure and it turns out to bear the same result.

I am wondering if anyone else has come across the above article, or have 
other ways to boot a Live Session off a network? Or perhaps simply give 
me some leads as why the above attempt had failed.



More information about the linux mailing list