[clug] Issues mounting a RHEL4 nfs export.

Robert robert at apex.net.au
Thu Jan 25 00:30:09 GMT 2007

Well, it sounds like the problems at the linux end, not the solaris end.
So tweaking the mount options probably isnt the solution.

I can confirm that Ive successfully mounted a nfs filesystem from a 
rhel4 box to a solaris 9 box, which should be similar enough.

Anything special about the filesystem?
What services do you have running?

I get this

chkconfig --list | grep -E 'port|nfs|rpc'
rpcgssd         0:off   1:off   2:off   3:on    4:on    5:on    6:off
nfslock         0:off   1:off   2:off   3:on    4:on    5:on    6:off
nfs             0:off   1:off   2:on    3:on    4:on    5:on    6:off
portmap         0:off   1:off   2:off   3:on    4:on    5:on    6:off
rpcidmapd       0:off   1:off   2:off   3:on    4:on    5:on    6:off

Probably not all of those are needed for nfs vers 3.

What does exportfs show.

Antony Wuth wrote:
> Good morning,
> I am currently trying to get a RHEL4 box to successfully export some
> filesystems via NFS to a solaris 8 machine.
> Currently the RHEL4 machine seems to be playing badly. The solaris end of
> the connection seems to just timeout with: NFS server xx.xx.xx not
> responding still trying.
> All the testing I have been doing (rcpinfo's etc) tells me everything 
> should
> be OK. We have tried to mount back to the same box that is exporting the
> filesystem (something I have never had to try before) and that fails in the
> same way. While testing we have tried just about every nfs option that
> appears in man mount_nfs & nothing seems to have made the problem better 
> (or
> worse).
> I am starting to wonder if there is an issue with the (horribly old)
> 2.6.9-34.ELsmp kernel the RHEL box appears to be running.
> Does anyone have any suggestions as to what to try next?
> Thanks
> Antony Wuth

If the Hunter S Thomson quote "When the going gets weird, the weird turn 
pro" is true, why aren't I rich?

More information about the linux mailing list