[clug] trouble unmounting /var on production system

Duncan Roe duncan_roe at acslink.net.au
Sat May 13 15:22:55 GMT 2006

Hi Tony,

The remount syntax is
   mount -oro,remount /var

"mount -r -oremount /var" should work as well I guess (from the man page) but I
never tried doing it that way.

just in case you were trying  w/out the "-o"

Cheers ... Duncan.

On Sat, May 13, 2006 at 10:55:23PM +1000, Tony and Robyn Lewis wrote:
> We have a box in a colo.  Filesystems are ext3 over LVM over RAID5.
> We've reached the point where we need to resize and increase /var, and
> we'd rather not pay access fees to sit at the box.
> Because it's ext3, I need to unmount the partition to resize it (BTW,
> did you know you can resize reiser partitions while they're mounted?
> Points awarded to reiser), but I can't unmount it.
> I've killed everything I can find that is reasonable.  "lsof +D /var"
> shows nothing.  "ps -ef | grep var" shows nothing.  "fuser -m /var"
> shows nothing.  But I can't unmount.  (BTW, I had to use all three of
> these to find processes using /var, which I found strange)
> I tried rebooting, and I tried "mount -r remount /var" first, but
> nothing seems to work.
> Anybody got any ideas?
> Tony
> --
> linux mailing list
> linux at lists.samba.org
> https://lists.samba.org/mailman/listinfo/linux

 Please avoid sending me Word or PowerPoint attachments.
 See http://www.gnu.org/philosophy/no-word-attachments.html

More information about the linux mailing list