[clug] QtParted with Knoppix

Al Kabaila akabaila at pcug.org.au
Mon Jan 16 22:08:07 GMT 2006


Thank you for your response.  By default, Knoppix makes all partitions on a 
disk "read only" and not mounted.  

From the GUI, I did r-click on each partion icon, selected properties and 
unselected the "read-only" option for the device.  Still no luck with the 
Linux partitions. 

When the partitons are mounted, they can then be read from and written to.  

QParted shows that the "disk is busy".  That could be because there is a 
(spare) swap partition on hdb (It used to be the main HDD, hda).  Still, no 
resize seems to be allowed on Linux partitions.  Weird that no such 
inhibitions about the fat32 partitions.

I like Knoppix - it is a classic.  Of course, I could (and probably will) 
change the partitions with the "Partition Magic 8 rescue floppies".  But I 
would prefer to do  that with Knoppix.

Thanks again,


On Monday 16 January 2006 23:53, Steve Walsh wrote:
> Al;
> Not all Live CD/CDFS's allow you to modify the installed hardware for
> security reasons. I know for a fact that the Gentoo Live CD's will allow
> you to modify the installed HDD, but I'm sure others on this list can offer
> some other solutions.
> Regards
> Steve
> -----Original Message-----
> From: Al Kabaila [mailto:akabaila at pcug.org.au]
> Sent: Monday, 16 January 2006 11:22 PM
> To: linux at lists.samba.org
> Subject: [clug] QtParted with Knoppix
> Hi,
> With Knoppix 4.0 DVD booted, I tried to use qtparted to adjust my hdb
> partition sizes, formatted with reiser file system.  No luck - the resize
> tool is greyed out.  That in turn indicates that the operation is
> "illegal".
> Interestingly, hdb1 and hdb2 are fat32 partitions and the resize tool is
> active for those partitions.  Weird.
> Is it qtparted, knoppix or just poor old newbie that I am?
> All hints appreciated,
> Al.
> --
> linux mailing list
> linux at lists.samba.org
> https://lists.samba.org/mailman/listinfo/linux

More information about the linux mailing list