[clug] Maxtor II One Touch and Linux

Brad Hards bradh at frogmouth.net
Mon Mar 7 07:15:32 GMT 2005

On Mon, 7 Mar 2005 05:24 pm, Pearl Louis wrote:
> Hi
> I'm thinking of buying a Maxtor One Touch II external hard drive.  I
> know it doesn't support Linux (officially), but I was wondering if it
> works in Linux at all?  I'm especially worried about the "DriveLock"
> feature.  Basically you cannot access the drive without a password.  To
> put in the password you need to use a special software utility.  Which I
> am 100% sure does not work with Linux.  Can you simply turn this feature
> off when you don't need it (obviously with a password...)?
There's a password feature? 

I have two OneTouch drives (although one is still in the wrapper - my MacMini 
only just got the point where there is something on it worth backing up). I 
haven't tried it with firewire, but the 300G works good with Linux 2.6.10 and 
USB2. No idea why you need to press the button, and I never have. I found it 
just worked.

Notes: this is a OneTouch, not sure if OneTouch II is the same. However if you 
look closely and it says it works with MacOS (but says the software won't), 
you probably have no problems.


More information about the linux mailing list