[clug] iPod shuffle issues

David Collett davico at tpg.com.au
Tue Jun 28 13:00:17 GMT 2005

My suspicion is that there is nothing special about the ipod shuffle
storage-wise compared to a regular usb thumbdrive. 

It has one partition (/dev/sda1) which starts at block 1, and contains a
windows fat32 filesystem (type 'b'). I dont know if the firmware is on
the same physical chips, but it certainly doesnt seem to be exposed
in /dev/sda anywhere, so you hopefully cant destroy it too easily with
mkfs/dd etc. I assume when you turn it on, the ipod firmware just mounts
the first partition (sda1), reads its itunes database from the
filesystem, then starts playing files from the filesystem.

To test the hw itself, you could try some reads and writes without using
the filesystem driver at all eg.

# (but I havent tried it)

# backup data
dd if=/dev/sda of=ipod.bkup

# write zeros (try this a few times)
dd if=/dev/zero of=/dev/sda

# put data back on
dd if=ipod.bkup of=/dev/sda

Check dmesg for errors while you are reading and writing (you shouldn't
get any)

Then to test filesystem issues, you could have a play with reformatting
it? You could even put a ext3 fs on it and see if that works for data
transfers under linux. To get the fat32 fs back you should be able to
just "mkfs -t vfat /dev/sda1" then use the gnupod tools or gtkpod to
recreate the directories and see if that works.

One more thing: If you are using a UTF-8 locale (and perhaps other non
C/POSIX/ISO-8859-1 ones), and you mount an msdos/vfat filesystem with
the default mount options, linux can create files which are case
sensitive leading to possible wierd behavior when mounted by other
systems (ipod firmware for instance). I read that in some gnupod doco I
think. It could cause playback problems, but it should not cause the
write errors you are experiencing I don't think.


On Tue, 2005-06-28 at 22:18 +1000, Michael Carden wrote:
> > I'm sorry you are having such trouble. It sounds like a
> > software/hardware combination on the PC end that is the issue, though
> > considering how many combinations you have tried, it is very odd.
> Indeed. Perhaps I ought to have ignored the default file systems.
> The application level stuff appears not so important in this case. I'm using 
> (or trying to use) rebuild_db.py (from sourceforge) as the shuffle database 
> rebuilder after I copy files across. Sometimes I get enough stuff across that 
> rebuild_db.py can work. Sometimes it crashes because the device unmounted in 
> the meantime.
> Then I can listen to one or two of the podcasted mp3s that actually made it.
> Yours clearly works in just the way that mine doesn't.
> I'm not familiar with the behaviour of file systems in general when stuff goes 
> bad, so I'm not sure where I ought to be looking.
> What I need is a pointer to something I can do with an iPod on one of my 
> machines that will help me to work out why it gets spat out.
> Ta,
> MC

More information about the linux mailing list