[clug] iPod shuffle issues

David Collett davico at tpg.com.au
Tue Jun 28 11:52:41 GMT 2005

Unfortunately I can't help you because I have had absolutely no problems
with my Wife's ipod  shuffle whatsoever :). I will continue for the sake
of documenting another users experience. 

Here's what I did:
1. pull shuffle out of box.

2. plug into Ubuntu.
- A few seconds later it pops up on the desktop.
- It was mounted as /media/IPOD, which is a symlink to /dev/sda1 (or
whatever your next sd device is), "IPOD" is actually the fat32 volume
name, ubuntu makes this link on-the-fly. 
- It IS pre-formatted with a fat32 filesystem, but it does NOT have the
required ipod/itunes directory structure and metadata files. (it looks
at this point like any other thumbdrive)

3. Install latest gnupod (the one in ubuntu is the release just prior to
adding shuffle support unfortunately).

4. run gnupod_INIT.pl to create the metadata dirs.
- You do NOT have to use windows OR mac AT ALL. (no accepting licence
agreements for me!)

5. use gnupod_addsong.pl to add mp3s to shuffle. Finish up by running

6. right-click IPOD desktop icon and unmount disk (or
umount /media/IPOD)

7. remove shuffle, get your groove on.

All this as a normal user, no formatting, no windows, no fuss. In fact
you can use gtkpod instead of gnupod, and you replace steps 3-5 above
with some clicking around in a pretty gui.

I'm sorry you are having such trouble. It sounds like a
software/hardware combination on the PC end that is the issue, though
considering how many combinations you have tried, it is very odd.


On Tue, 2005-06-28 at 21:23 +1000, Michael Carden wrote:
> The story so far. Apologies to those who have seen this before.
> I got an iPod Shuffle. Actually, I got nine of them, but let's leave that 
> aside for now.
> I wish to use the shuffle with a number of different Linux boxes.
> My principle use is to play podcasts that a cron job grabs for me every night 
> using bashpodder. 
> http://linc.homeunix.org:8080/scripts/bashpodder/
> http://abc.net.au/rn/podcast/
> iPods have to be initially formatted with a mac for hfs or a winbox for vfat. 
> I use a winbox and do it with vfat.
> Early on, I found that my iPod had troubles on a Linux machine. On my 2.4.27 
> kernel AMDK6 box, it mounts okay, but when you try to copy stuff to it, after 
> a random amount of time (usually part way through the copy) it spits the 
> dummy. The copy fails with a message about a read-only file system. A look 
> at /var/log/messages shows that the iPod has experienced a 'file system 
> panic' and has unmounted and remounted as read only.
> I tried it on my 2.6 kernelled G3 Powerbook and the same thing happens.
> I handed it to Mikal Still and his 2.6 kernelled IBM Thinkpad copied one 
> metric buttload of data to it with no trouble at all. Maybe the 'laying on of 
> hands' was in effect?
> I have since tried it on Ubuntu, Kubuntu (both hoary), Suse 9, RHES3 and 4 and  
> Mandrake 10 on mostly Intel hardware from PIII 700s through 2.4 G Xeons to P4 
> HT 3.0... the same thing happens. *If* I can mount it (I usually have to read 
> the log to find out what the kernel saw then manually mount it), it doesn't 
> stay mounted long if I write to it.
> Hmmm. A hardware fault, surely. Well I did say that I had nine of them... A 
> second one behaves in the same way, so that appears unlikely.
> Another data point is that Win2k and XP machines have no trouble with the 
> iPod. Also if I connect it to anything via the hub on a Belkin USB kvm 
> switch, no host machine can see it, but a generic 128meg USB key on the same 
> port is detected by any machine.
> Can a clever USB person (Brad?) point me in the right direction?
> Oddly, some extended Googling on groups and web hasn't found anyone else 
> experiencing the problem and I'm surprised that no one else has been here 
> before...
> The shuffle is a coolish toy, even if some memory card based players are more 
> flexible. I'd like to use my iPod(s) with Linux and right now I'm running 
> into a wall.
> MC

More information about the linux mailing list