[clug] IPW2200 + WPA Support Anyone?

Russell Zweck rzweck at ozemail.com.au
Thu Jun 16 14:12:24 GMT 2005


I am running a Dell 9300 laptop with the ipw2200 driver running kubuntu 
5.04 using WPA-PSK for encryption.  Kubuntu 5.04 (hoary hedgehog) ran 
the wireless card out of the box - but not with WPA.  I only got it 
working finally today after several days of trying.  I don't know 
exactly which step worked but it was definitely to with setting up the 
wpa_supplicant software and associated scripts and config files.  I got 
it working from information and scripts from the below links.  Nothing I 
found worked exactly without some modification, but they gave me enough 
of a start.

After I loaded wpa_supplicant software, I didn't need to load any other 
crypto software from memory, as I think that some is supplied with 

try this link for ubuntu which may help:

I also found these links which may be of use:

I hope this helps.  I can give you some more details if this doesn't get 
you very far.


Frank Turcic wrote:

>Has anyone been able to get WPA to work with the current release of IPW2200?
>If so then I'm interested in your experiences as I am stumped!  I was
>tempted to set WEP encryption on my AP but I think that's just the easy way
>out (and insecure).  I am using Fedora Core 4 on a Centrino based laptop.  
>I have followed the INSTALL (http://ipw2200.sourceforge.net/INSTALL) in
>order to get the card working with WEP, although, I am stuck at the bit were
>it mentions to enable the Michael MIC (CONFIG_CRYPTO_MICHAEL_MIC) and AES
>(CONFIG_CRYPTO_AES_586) Crypto library modules (step required to get WPA
>Are the crypto library modules available via a yum repository?  I understand
>that WPA isn't "officially" supported, but, with the amount of Centrino
>linux users out there I am sure someone should have the configuration down
>to a t!

More information about the linux mailing list