[clug] writing to mount filesystem

Joel Plane joel at korgsit.com
Sat Jan 29 08:48:15 GMT 2005

That worked for the Samba share. I haven't tried with the FAT32 fs yet 
but I assume the solution will be similar.

Thanks Nathan

Joel Plane.

Nathan Robertson wrote:

> Hi Joel,
> On 29/01/2005, at 6:21 PM, Joel Plane wrote:
>> I have an SMB filesystem mounted at /mnt/data. I can only write to it 
>> as root.
>> I also have a local FAT32 filesystem mounted to /data. Again, I can 
>> only write to it as root. The mount point itself has permissions set 
>> to 777.
>> Any ideas?
> There are plenty of options for smbmount (which is what "mount -t 
> smbfs" is). Type "smbmount --help", and it'll give you all the 
> details. Specifically, you want the "uid" and / or "gid" parameters to 
> be your user id, and some group id if you want multiple people to be 
> able to write to the share. "fmask" and "dmask" may also be useful to 
> set file permissions on files and directories on the mount, and 
> potentially want the "rw" option to specify read/write permissions.
> Regards,
> Nathan.

More information about the linux mailing list