[clug] boot time issue

btwyss at netspeed.com.au btwyss at netspeed.com.au
Fri Mar 19 03:54:10 GMT 2004

Quoting David Tulloh <david.tulloh at infaze.com.au>:

> Benedict and Trisha Wyss wrote:
> > Hi all,
> > 
> > this is my first posting of the questioning type so bear with me.
> > 
> > I have just built fresh a rh8 box on a compq pro workstation.
> Unfortunatly
> > durring boot it will only see the MBR every now and then and always with
> the
> > recovery disk otherwise producing the following error "No System disk or
> > disk error replace and strike any key when ready". I am reasonably happy
> > that sda's boot sector etc are ok and functioning as it works perfectly
> with
> > the diskette. My question here is do I rebuild and hope this rectifies
> the
> > issue or is there a repair tool known to you guys??
> Ok:
> boots with disk
> doesn't boot with hard drive (I'm a little worried about the 'now and
> then')
Just to clarify, it will boot ONLY after I have previously booted with the 
recovery diskette. So it does find grub in the first/boot sector/partition.
> I suspect the problem is that grub is not installed in the mbr.  During 
> the installation process you are presented with a choice of installing 
> the boot loader into the MBR or the boot partition, in which case you 
> would need to use another boot loader in the MBR.  I suspect that you 
> have chosen to put grub in the boot partition rather than the MBR, 
> leaving the MBR empty... hence the no disk found error.  I'm hoping that 
> someone else can provide a second opinion on this matter.
I did also select the boot partition as you point out above and I ran the 
install twice with the same result (maybe a corrupt part and the hdd heeds a 
low level format??)
> It is possible to fix this problem using the grub shell.
> I hesitate to provide any specifics as the commands given vary on your 
> hardware layout and it would be very easy to hurt something if I assumed 
> anything about your layout.  Instead, some further reading:
> http://www.gnu.org/software/grub/manual/
> http://www.mcc.ac.uk/grub/grub_toc.html  (same as above, but works)
> http://www.fr.linuxfromscratch.org/view/lfs-5.0/chapter08/grub.html
I will try the links above and see how I go, thanks.
> > 
> > The other point is there are 2 entries in grub.conf (see below) and am
> > wondering why or what is the difference when booted?
> > ____________________________________
> > title Red Hat Linux (2.4.18-14smp)
> > 	root (hd0,0)
> > 	kernel /vmlinuz-2.4.18-14smp ro root=LABEL=/ vga=0x314
> > 	initrd /initrd-2.4.18-14smp.img
> > title Red Hat Linux-up (2.4.18-14)
> > 	root (hd0,0)
> > 	kernel /vmlinuz-2.4.18-14 ro root=LABEL=/
> > 	initrd /initrd-2.4.18-14.img
> > _____________________________________
> The smp kernel version is for multi-processor systems.  If you only have 
> one processor the bottom option is faster, however both should work. 
> You can delete whichever option you do not use.
It is infact a dual processor machine (PIII 700mhz), so thanks also for 
clarifying that, I will leave that as is.
> Hope it all works out for you.
> David

More information about the linux mailing list