[clug] Wierd problem connecting to www.mozilla.organdwww.microsoft.com

Donovan J. Edye donovan at edyeweb.com
Thu Dec 16 09:02:00 GMT 2004


- Thanks for your time and help. I will have a play and see what I can find.


-----Original Message-----
From: Dale Shaw [mailto:dale.shaw at gmail.com] 
Sent: Thursday, 16 December 2004 18:50
To: donovan at edyeweb.com
Cc: Linux List
Subject: Re: [clug] Wierd problem connecting to


Your D-Link modem is probably using PPPoE. I believe the D-Link 504s
can use PPPoE or PPPoA. If you can, try changing it to use PPPoA -
that should eliminate headaches with MTU and Path MTU Discovery
(maybe). Have a play.

There MUST be something filtering ICMP between your XP box and
Microsoft's web site, and it's probably something pretty close to home
(i.e. something you own/manage or something one or two hops upstream).
I think even the built-in packet filter in XP is smart enough to
permit certain ICMP unreachables inbound, but if you've played with
the settings it would be worth double-checking the config.

Now that you've changed your gateway to be the D-Link, I suppose it's
possible there is some filtering going on there, but it would've been
something you manually configured because I vaguely recall (from the 1
D-Link 504 that I've seen) that by default it just does NAT (no packet

Anyway, you shouldn't have to change the MTU to make it work - it's
just the symptom of another problem - ICMP unreachable type 3/code 4
packets are not reaching your XP box. ICMP 3/4 packets are generated
when a router or something upstream has to fragment the IP packet
because, with protocol overhead, it is too large to send to the next
hop. However, it can't fragment the packet because the original packet
sent from your XP box has the DF (Don't Fragment) bit set. That is the

Perhaps I led you slightly astray before and the reghack changed the
Ethernet MTU as distinct from the IP MTU. I'm not sure.


On Thu, 16 Dec 2004 17:51:32 +1100, Donovan J. Edye <donovan at edyeweb.com>
> D,
> > I don't think the MTU thing worked.
> Correct. I installed DrTCP and it had not taken. Made it 1300.
> and now www.microsoft.com opens!!!!
> Now what I want to know is what is the MTU really and why has this worked?
> --D

More information about the linux mailing list