[clug] xorg and nvidia problem

freegazer freegazer at gmail.com
Wed Dec 15 01:12:32 GMT 2004

<signature block>
Rule #35
That which does not kill you has made a tactical error.
</signature>i'm looking for help with an x-server issue
having just upgraded to Xorg as part of mandrake upgrade/reinstall I
liked it and went about installing the latest NVidia-installer. things
have gone downhill since, i can still get my default x-server running
using the "nv" driver but its a poor comparison.

initial problem was no screens were found. Resolution: no
kernel-sources rpms installed with mdk10.1beta1 CE (hmmm, interesting
installation i guess :)

latest problem is the NVidia module does not load during startx
causing the error no devices found is given.
i have just noticied also that nvidia installation greates XF86Config
where as X is using Xorg.conf but they are identical according to diff

i have tried manual loading with 
# modprobe (no errors) 
$ startx
i have tried editing the following
   modprobe.preload #change the default AGP handler
   rc.local                 #add the node devices (with (AFAIK)
correct major/minor listings)
   xorg.conf              #of course
but also no good!

more error info/logs available if requested
does anyone have any ideas / experince with resolving xorg issues?

More information about the linux mailing list