[clug] Access VNC server via DNAT

Joel Pearson pearj at writeme.com
Sun Sep 21 15:18:12 EST 2003

Hey Everyone,

It turns out my local firewall was doing something screwy to vnc when I was
trying to connect to the remote host and vncviewer wasn't masquerading
properly.  I restarted iptables and lo and behold dnat is working happily.
I have a feeling it was working all along.

So thanks to all the people that tried to figure out the problem when it was
really already fixed. :-S


"Joel Pearson" <pearj at writeme.com> wrote in
message news:bkhku9$9v3$1 at sea.gmane.org...
> Hey,
> I have a vnc server that is on my local lan at home that I'd like to be
> to access from the internet via my internet gateway linux box.  I've read
> little bit about it but I can't get my gateway to forward to ports, I've
> tried this:
> iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 5904 -s -j
> DNAT --to
> But it says it can't connect to the server. At the moment I'm just trying
> get the port forwarding to work on my local lan, but it doesn't seem to be
> working. I've read of people haveing this working using a somewhat similar
> iptables command, is there some module I'm supposed to load to make this
> happen?  My server is running RedHat 8 with iptables v1.2.6a
> Does anyone know why this isn't working?
> Thanks
> Joel

More information about the linux mailing list