[clug] Access VNC server via DNAT

Joel Pearson pearj at writeme.com
Sat Sep 20 23:47:40 EST 2003


Ip forwarding is turned on, because ip masq works fine, but I just can't
make port forwarding work.
I tried omitting the port on the destination, but it didn't make any


"Damien Elmes" <clug at repose.cx> wrote in
message news:86n0czy40n.fsf at mobile.repose.cx...
> "Joel Pearson" <pearj at writeme.com> writes:
> > Hey,
> >
> > I have a vnc server that is on my local lan at home that I'd like to be
> > to access from the internet via my internet gateway linux box.  I've
read a
> > little bit about it but I can't get my gateway to forward to ports, I've
> > tried this:
> > iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 5904 -s -j
> > DNAT --to
> > But it says it can't connect to the server. At the moment I'm just
trying to
> > get the port forwarding to work on my local lan, but it doesn't seem to
> > working. I've read of people haveing this working using a somewhat
> > iptables command, is there some module I'm supposed to load to make this
> > happen?  My server is running RedHat 8 with iptables v1.2.6a
> >
> > Does anyone know why this isn't working?
> Have you turned on ip forwarding?
> echo 1 > /proc/sys/net/ipv4/ip_forward
> (off the top of my head - path might be slightly different).
> Also, I think you can omit the port on the destination.
> Cheers,
> -- 
> Damien Elmes

More information about the linux mailing list