[clug] Fun with RPM's

Steve Jenkin sjenkin at canb.auug.org.au
Mon Oct 13 18:29:31 EST 2003

Thought I'd share with the list the way I wasted most of my last 24hrs

The laptop I've got on loan has Knoppix/Debian.  I upgraded to
OpenOffice.org 1.1 - quick simple, Just Worked.

On my RH8 box at home - thought last night ~6pm - "Hey - Why not O-O
I've got a copy of RH9 - it'll be on there.  Or if not, I can fetch it
off some RPM mirror & it will need all these new dependencies anyway.

Looked at the RPMS on the disk - found O-O 1.0.2].
Tried to load - wanted to upgrade glibc [to 3.2].
Went for a full upgrade.

Took till after 1AM to get past the 'you don't have enough space on the
partition' message.  It's a 20Gb drive & half given over to RH [7Gb in
/, 3Gb in /usr/local]  Needed 750Mb more [Install 3.9Gb]  Trimmed this
down to under 2.7Gb - still 'not enough space'.  Finally forced it to
ignore dependencies [not nice].  Left it running with 2.5hrs expected.
Got up 5:15 to load 2nd disk.  Came back @ 7am -> had stopped the
upgrade 'cause of a disk error!  

upgrade.log said it wanted to do 969 packages.  It got about 460 done.

This could have been Real Bad!

System booted (whew!), then this morning I moved the 1.5Gb I had saved
in /var to /usr/local.  Update went like a charm - still near 2Hr...

Should've done the cleanup last night - but I was confused and thought I
would save time by not rebooting. [Hindsight is 20-20, eh?!]

So, got the system built & working.  O-O worked too.

Went looking for an O-O 1.1 => no such thing!  Not happy, Jan.
Grabbed the 78Mb tarball from planetmirror, and did the install thing.
Sorta works - not properly integrated with the KDE menus, though - had
to do stuff by hand.

- Was lucky when the media failed.  Left with a bootable system.
- When RH upgrade says 'not enough space' - then reboot, cleanup &
- I'm really surprised there's no RPM for O-O 1.1!!


Steve Jenkin <sjenkin at canb.auug.org.au>

More information about the linux mailing list