[clug] fsck.ext3 errors output - partitioning a contributor?

Daniel cottmain at plug.linux.org.au
Tue May 27 19:28:37 EST 2003

On Fri, 2003-05-23 at 15:59, Martijn van Oosterhout wrote: 
> On Thu, May 22, 2003 at 08:06:24PM +0800, Daniel wrote:
> > Does this indicate the drive is 'on the way out' or might there be a
> > chance I contributed to the situation by incorrect partition sizes?
> > Should a partition be a base 2 size?
> Looks like the partition table thinks the disk is bigger than it really is.
> Looking at the bootup messages would give you some idea. Since you've now
> reformatted it should be ok. What partitioning program did you use?
> -- 
> Martijn van Oosterhout   <kleptog at svana.org>   http://svana.org/kleptog/

Thanks very much Martin and Martijn and all for your help.
I originally used linux fdisk v2.11n then formatted as ext3 [mkfs.ext3]
I think the disk has two problems - me using fsck incorrectly and disk

a)when I thought there were problems with the disk I used fsck.ext3, but
probably with the wrong settings -cvp.  Guess I should have used "-nv"
for anything with data on it and jump to "-pv" if it reports problems
and I have no other solution and nothing to lose.  

As a preparation of a freshly formatted data free disk I think I would
use: "-cv" or "-ccv". (right?)

b)dmesg showed you are right - it thinks my 40g drive is 33g: 
hdb: 66055248 sectors (33820 MB) w/1820KiB Cache, CHS=4111/255/63,
blk: queue c030a0a8, I/O limit 4095Mb (mask 0xffffffff) 
I blanked the mbr with dd then I downloaded the Maxtor format floppy
.... only to still get 33gig.  I used cfdisk -z and tried the change the
drive to the heads and cylinder details I found on the net - only to
find they wouldn't stick and I  have 33g still. Even allowing for the
alternative interpretation of hard drive sellers 40,000,000 / 1024 /1024
= 38 not 33. I ran the full fsck on the freshly formatted disk and got
no errors. Looks like I'm still doing something wrong!


More information about the linux mailing list