[clug] reiserfs problem

Kim Holburn kim.holburn at anu.edu.au
Tue Aug 12 22:24:12 EST 2003

At 9:30 PM +1000 2003/08/12, Martin Pool wrote:
>On 12 Aug 2003, Kim Holburn <kim.holburn at anu.edu.au> wrote:
>> Yeah, it was a brand new disk.  I created a partition.  I'm sure
>> I've done that lots of times and not had to reboot to get the kernel
>> to see it.  What exactly does "any of the partitions are in use"
>> mean?
>Mounted, or open as a raw device (by mkfs, fsck, etc).  You will see a
>kernel message when the partition table is re-read.  If you don't see
>the message, they haven't been reread and as far as the kernel is
>concerned they still have their old locations.

As I said, a new disk, never used before AFAIK, no partitions, I created 1 partition then tried to run mkreiserfs.  Never "used" it at all.  How could I, it had nothing on it?

I've seen messages before when using fdisk or cfdisk saying I should reboot but always ignored it and ran mkfs or whatever and it just worked.

Kim Holburn 
Network Consultant - Telecommunications Engineering
Research School of Information Sciences and Engineering
Australian National University - Ph: +61 2 61258620 M: +61 0417820641
Email: kim.holburn at anu.edu.au  - PGP Public Key on request

Life is complex - It has real and imaginary parts.
     Andrea Leistra (rec.arts.sf.written.Robert-jordan)

More information about the linux mailing list