[clug] Ext3 /var is full but not?

Stephen Jenkin sjenkin at pcug.org.au
Fri Apr 11 09:31:02 EST 2003

Is this the 'unnamed inode' problem??  In Unix inodes are files - and they
do not have to appear in a filesystem/directory.  They are files held open
by processes.  When the file is closed, the inode & its space are

'df' reports real file system numbers [remembering that BSD 'ffs' like
file systems reserve 10% of space.  Normal users get 'disk full' at this
point, privileged users get the real 100%]

'du' goes through the inodes in the directory tree totaling space - and by
definition misses unnamed open inodes.

'lsof' is your friend :-)  lsof /dev/hda5 [or /var]

Here's some output [spot the cheat - I moved the heading line by hand]
[root at grub root]# lsof /dev/hdb8|sort +6nr|head -4
nmbd       898 root    3w   REG   3,72 536775 1485124 /var/log/samba/log.nmbd
nmbd       900 root    3w   REG   3,72 536775 1485124 /var/log/samba/log.nmbd
kdm       1067 root    9u  FIFO   3,72         489604 /var/run/xdmctl/xdmctl-:0

Steve Jenkin, Unix Sys Admin
0412 786 915 (+61 412 786 915)
PO Box 48, Kippax ACT 2615, AUSTRALIA

On Fri, 11 Apr 2003, Michael Still wrote:

> Hey,
> I have a /var whihc is 400mb. It only has just over 100mb on it, but when
> you try to add data (e.g. echo "foo" > /var/foo) I get back a "no space on
> device" message.
> I've tried reducing the reserved percentage. I've tried rebooting, so it's
> not old filehandles (although it was happy briefly after a reboot).
> Any ideas whats happened and how to fix it? It's very annoying, as my DNS,
> DHCP, NFS servers all now refuse to respond...
> Thanks,
> Mikal
> -- 
> Michael Still (mikal at stillhq.com) | Stage 1: Steal underpants
> http://www.stillhq.com            | Stage 2: ????
> UTC + 10                          | Stage 3: Profit

More information about the linux mailing list