large disks in old machines

Rob Shugg rshugg at
Tue Sep 3 00:29:03 EST 2002

I took Michaels suggestion and it got a Promise Ultra 100 TX2 card. All fixed.
everything autodetected, no size limiting jumper or CHS forcing.
very good.

one interesting thing though, i plugged my 30G WD in to this to copy its 
contents over and i still couldn't mount it. I suspect a version problem 
between MDK 8.2 reiserfs and debian Woody's...(any comments welome)
I may just copy it over NFS anyway.


On Monday 26 August 2002 9:01 pm, Martijn van Oosterhout wrote:
> On Mon, Aug 26, 2002 at 12:04:27PM +1000, Rob Shugg wrote:
> > Hey
> > I am setting up some file servers on old P2's and have come across some
> > problems.
> >
> > the disk is a Seagate Barracuda 80G.
> > initially i had no joy on the pentium 2 so I put it in my newer P3 and it
> > detected ok. I then tried fdisk but it complained about the partition
> > table being missing. I had to use sfdisk to write a partition table and I
> > had to manually set the C,H,S values as the kernel had got it wrong. I
> > then made a reiserfs and mounted it ok.
> I've put an 80G disk in a machine whose bios just hung when trying to
> detect it. The first thing I tried was to leave it out of the BIOS (say
> None rather than Auto). That worked and Linux correctly detected it. It
> worked fine.
> What I also did was fill in the wrong size of the disk in the BIOS (was a
> bit tricky since the BIOS kept hanging if I pressed the wrong key). I think
> I did 16383/254/16. The BIOS then booted, linux got the correct size and I
> got UDMA support to boot :).
> Oh yeah, don't force the C,H,S. The kernel is almost always right if it
> determined the size properly. If the BIOS didn't put the drive into LBA
> mode, forcing the C,H,S may leave you unable to access the disk properly.
> > I then tried to copy about 20G over to it. I got a few IDE timeouts and
> > CRC errors doing this. So then I put it on an 80 wire ide cable, made a
> > new fs and repeated the copy with no errors.
> That's wierd.
> > That was on a Mandrake 8.1 box. the fileserver is Debian woody, I wanted
> > to mount this disk on /home in that box.
> > I had to put the "limit drive capacity to 30G" jumper in in order to get
> > the bios to detect it. that was fine. The trouble is it wont mount the
> > filesystem.
> > I get page full of errors ending in something like "bad filesystem" This
> > box supports reiserfs. I thought this might be a version problem for
> > reiserfs between the debian and MDK systems.
> Careful with that jumper. It might actually cap the size of the drive,
> making it somewhat useless if you want to use the whole disk. I think you
> might need that tricky software to then use the whole disk. Best leave it
> off.
> > I then tried to create a ext3 fs on the debian box but this produced a
> > stack of CRC errors and IDE resets. These errors looked similar to ones
> > that were fixed with the 80 wire cable so I thought i would try that.
> > This was not possible because the cable I have has 39 pins (one blank for
> > orientation) and my motherboard has the full 40 pins.
> >
> > Questions:
> > has anyone else experienced this or do I have a dud disk?
> > do i need to put a PCI IDE card in the P2 to support the new disk?
> > do all 80 wire cables have 39 pins?
> I've had similar stuff with a Western Digital. Not telling the BIOS about
> it was certainly the quick fix. Alternativly, lying about the size may work
> too. That jumper and overriding the C,H,S seems certainly not the wat to
> go.
> Hope this helps,

More information about the linux mailing list