Problem loading scsi driver

Neil Muller neil at
Wed May 15 22:35:10 EST 2002

The only info I can find for Tekram is for their DC390 not the DC315-U. 
Even though they claim Linux compatibility on their packaging, their web 
site doesn't confirm this and they don't provide any of their own 
drivers for it. I downloaded the drivers Tekram say are supposed to 
support the DC315-U on Linux but the files are labelled for for the 
DC390 and when compiled they have unresolved symbols, hence I guess the 
problems I'm having :-) .


Antti.Roppola at wrote:

>Does Red Hat 7.2 use a 2.2 or 2.4 kernel?
>I had to patch a driver for Tekram's own chipset into 2.2 (Some Tekrams
>also use NCR chips) and found that while it worked, I wasn't prepared to
>use it on my fileserver. The other day I noticed support for Tekram's
>own SCSI chip is included in 2.4. Maybe try compiling up your own kernel?
>I wouldn't ditch the card just yet. Hopefully things are a lot
>better for the Tekram chipset than they were when I last tried. :o)
>-----Original Message-----
>From: Neil Muller [mailto:neil at]
>Sent: Tuesday, 14 May 2002 10:21 PM
>To: Linux-Samba
>Subject: Problem loading scsi driver
>Hi everyone,
>I've got a problem with a Tekram DC-315U scsi card driver I'm trying to 
>get RH7.2 to load. Because it was a new RH7.2 install I used the 'linux 
>dd' option at the start of the install to load the drivers, however when 
>I check the logs it says insmod is unable to load the driver. All I get 
>is ....
>insmod: /lib/modules/.../drivers/scsi/dc395x_trm.o: insmod 
>scsi_hostadapter failed
>.... in the logs.
>Does anyone have any ideas how to fix this?

Neologix Pty Ltd
ABN     89 080 124 965
email:  neil at
mob:    0408 977 976
office: +61 2 6287 5900
fax:    +61 2 6287 6911

More information about the linux mailing list