Problem loading scsi driver

Antti.Roppola at Antti.Roppola at
Wed May 15 10:13:33 EST 2002

Does Red Hat 7.2 use a 2.2 or 2.4 kernel?

I had to patch a driver for Tekram's own chipset into 2.2 (Some Tekrams
also use NCR chips) and found that while it worked, I wasn't prepared to
use it on my fileserver. The other day I noticed support for Tekram's
own SCSI chip is included in 2.4. Maybe try compiling up your own kernel?

I wouldn't ditch the card just yet. Hopefully things are a lot
better for the Tekram chipset than they were when I last tried. :o)


-----Original Message-----
From: Neil Muller [mailto:neil at]
Sent: Tuesday, 14 May 2002 10:21 PM
To: Linux-Samba
Subject: Problem loading scsi driver

Hi everyone,

I've got a problem with a Tekram DC-315U scsi card driver I'm trying to 
get RH7.2 to load. Because it was a new RH7.2 install I used the 'linux 
dd' option at the start of the install to load the drivers, however when 
I check the logs it says insmod is unable to load the driver. All I get 
is ....

insmod: /lib/modules/.../drivers/scsi/dc395x_trm.o: insmod 
scsi_hostadapter failed

.... in the logs.

Does anyone have any ideas how to fix this?


More information about the linux mailing list