dd command to copy a cd to a hard disk - Input/output error

Brett Worth brettw at cray.com.au
Sat Mar 30 14:32:53 EST 2002

On Sat, 30 Mar 2002, Daniel wrote:

> I wonder if anyone can help me please:
> I have tried to copy a cd to hdd on Mandrake 8.1 and Redhat 7.2 (I've done 
> it before, but this time it's not working):
> dd if=/dev/cdrom of=Mandrake82-cd1-inst.i586.iso
> dd: reading '/dev/cdrom': Input/output error
> 1332304+0 records in
> 1332304+0 records out

Looks OK to me...

The error is just the dd running off the end of the CD.  The fact that you
read ~760Mb means its probably OK.

You might speed it up a bit if you specified a larger block size than the
default 512bytes but you'll still get an error unless you specify a "count".

I think there might be a way to determine the actual number of blocks in a
track but running off the end like you've done works for me.  I guess it
might not work if you has a real error on the CD somewhere near the end of
the track.  In other words, you think its run off the end but its actually
hit a real error.


More information about the linux mailing list