Booting from Large Hard Disk/LILO

Mark Paine mpainf at
Tue Mar 12 20:39:28 EST 2002

Rodney Peters wrote:
> On Wednesday 06 March 2002 16:57, Mark Paine <mpainf at> wrote
> [stuff deleted]
> If that still does not give consistent CHS, then you might firstly need to
> use dd to zero out the first sector of /dev/hda, as the disk was probably
> pre-partitioned by the manufacturer using a different utility.  Detailed
> instructions are in the documentation for lvm.  This will, of course, totally
> obliterate the partition table and make your data unrecoverable !!.

Hadn't thought of zeroing out the partition table.  I can't remember if
fdisk/cfdisk indicated that there was no partition table at all.  Of
course, its a little late to wipe the disk at the moment.....
> > However, when it came to install LILO, it always failed on booting by
> > stopping at LI which I believe indicates a drive geometry problem.  No
> > matter what geometry I put in LILO (using the disk option), or even with
> > hde parameters for the kernel (which really should not be a problem I
> > think), I can't get the system to boot from the 40G drive while on the
> > HPT366 controller.  Options such as LBA32 and linear have no effect at
> > all.  (One thing I have not tried is booting it from the main IDE
> > channels, but then its running as a ATA/33 which is not really what I
> > want.)
> >
> Before getting too involved with the ATA66 controller it would be worth
> installing the 40 gig in a running linux system and running:
>         hdparm -t  /dev/hd[whatever it is]
> I've not found a 5400 rpm drive that delivers more than 15 MB/s in practice -
> can't see the point in 66 MB/s if you've got only one drive on the channel.

Actually, the 40G is a 7200 rpm drive.  Doing a hdparm -t on it returns
around 15MB/s.  The cache read is somewhat faster at around 60MB/s. 
This is twice the transfer from the old 20G 5400rpm drive on the ATA33
> > I am currently booting from a floppy then to the HD and all appears to
> > be running fine with no problems so Linux seems to recognise the drive
> > OK.
> >
> > The problem with booting though is bugging me.  I suspect that it is a
> > BIOS problem, but the BIOS for the HPT366 is part of the motherboard
> > BIOS.  I am not running the latest version of themotherboard BIOS, but
> > on the Abit web site I can see no changes that would affect the HPT366
> > BIOS.  There are no options in the HPT366 BIOS that affect drive
> > configuration, unlike the main BIOS, so I can't over ride what the
> > HPT366 BIOS is sensing the drive as.
> >
> I'm not familiar with the HPT366, however, it's implementation as additional
> channels on your mobo may not support booting at all.  A quick test might be
> to try any known, bootable HDD on it.  Does the main BIOS allow "hde" in the
> boot sequence ?

There is a BIOS option which allows me to boot from the ATA66 channels. 
It works, which is why LILO only gets as far as LI in the booting phase.

I have been able to get it booting thanks to Michael James and a problem
report he found on SUSE.  (Thanks Mike!!).  What ended up working was
converting the drive geometry from its 77545/16/63 to 4866/255/63 which
appears to be a more 'acceptable' LBA geometry for LILO.  These new
figures were put into a disk section in lilo.conf, rewrote the MBR,
rebooted and it all worked wonderfully.  I think LILO was trying to get
a valid LBA geometry (ie x/255/63) but was not getting it.  Giving it
one, and then letting the kernel accept what the drive/BIOS reports
appears to be working.  The CHS I think is not really important, as its
all LBA access anyway.

Mark P.
.sig - TBA

More information about the linux mailing list