smoothwall transact issues

Richard Cottrill richard_c at
Mon Jan 14 21:18:44 EST 2002

I've been increasingly interested by IPCop as Smoothwall Inc. writes more
and more proprietary code. I don't necessarily see Richard Morrell
(Smoothwall funder and founder) as evil; but to call him a free software
developer is perhaps a bit much. The GPL Smoothwall is as the shareware DOOM
was to Q3A.

There are unlikely to be significant improvements to the GPLed Smoothwall
variant. I run Smoothwall at home, but I will change to IPCop when I feel
that I need/want to change my firewall set-up. If/when I get my shit
together and make my Smoothwall box fully h.323 transparent (as far as it's
possible) I'll contribute a version to both products under the GPL. I expect
that it would be refused by the Smoothwall people for their GPL version and
eventually re-implemented as an add-on module for the not-free versions.

The possible benefit for Linux as a whole from the Smoothwall people
(whether their products are free or not) is that they enthusiastically
contribute patches and fixes to the kernel (and other bits) of Linux (unlike
a large Australian ISP that will remain nameless). Kudos where it's due -
they do believe in free Linux but they're also fond of eating.

However I don't have any experience with IPCop and if anyone can give
pointers about how well it works I'd appreciate it.


> -----Original Message-----
> From: linux-admin at [mailto:linux-admin at]On
> Behalf Of rob shugg
> Sent: Saturday, January 12, 2002 10:22 PM
> To: linux at
> Subject: smoothwall transact issues
> I'm trying to bet transact going with smoothwall but with little
> success. here is the connection log:
> 20:42:45 pppd pppd 2.3.11 started by nobody, uid 99
> 20:42:45 pppd Using interface ppp0
> 20:42:45 pppd Connect: ppp0 <--> /dev/ttyp6
> 20:42:45 pppoe PPP session is 1010
> 20:42:46 pppd Warning - secret file
> /etc/ppp/pap-secrets has world and/or group
> access
> 20:42:48 pppd Warning - secret
> file /etc/ppp/pap-secrets has world and/or group access
> 20:42:49 pppd PAP authentication failed
> 20:42:49 pppd Connection terminated.
> 20:42:49 pppoe read (asyncReadFromPPP): Input/output error
> 20:42:49 pppoe Sent PADT
> 20:42:49 pppd Exit.
> any suggestions?
> Also has anyone tried ipcop?
> Rob

More information about the linux mailing list