gdm/PAM won't log in

Antti.Roppola at Antti.Roppola at
Wed Jan 2 15:01:13 EST 2002


Removed /etc/gdm/PreSession/Default (which tried calling /usr/bin/X11/sessreg
which doesn't exist) and it's all running.

Not sure how that could have changed as I haven't been here. *shrug*


-----Original Message-----
From: Antti.Roppola at [mailto:Antti.Roppola at]
Sent: Wednesday, 2 January 2002 12:42 PM
To: linux at
Subject: gdm/PAM won't log in

Hello all,

I have just got back from a month off and my desktop
Debian machine won't let me log in via gdm.

I can remotely log in, stop gdm, then log in locally and
start X manually. But if I use any good username/passwd at
the GDM login screen (including root), nothing happens except:

auth.log says:
	PAM_unix[4530]: authentication failure; <uid=0> -> **unknown** for gdm service
	gdm[4530]: Couldn't authenticate antti

I have tried a few things including resetting the password,
restarting gdm, looking at pam.d/gdm, frobbing init and in
desperation, rebooting. No cigar.

Any other ideas?



More information about the linux mailing list