Getting a BJC2100SP to work

Damien Elmes resolve at
Sun Feb 10 16:51:28 EST 2002

Richard Rose <richard58 at> writes:

> On Mon, 4 Feb 2002 22:52, you wrote:
> > On Mon, 4 Feb 2002, Richard Rose wrote:
> > > > What happened when  you sent plain text to /dev/lp0? Did it give you an
> > > > error, or just swallow it? A strace may be useful.
> > >
> > > No errors, is seemed to just swallow it. Never used strace before.
> >
> > Well, now's as good a time as any :-)
> >
> > strace -f -s 8000 -o ~/mystrace cat /etc/passwd > /dev/lp0
> >
> > man strace will tell you what those options do. They mail hardly any of
> > the passwd file to me at all. The -f is habit.
> >
> Well, I tried doing a strace (the results are attached) and I had a look at 
> status.Canon and, as far as I can tell, the printer stuff isn't going through 
> GhostScript. Can someone look at the attached files and tell me what I am 
> missing and where I should put it. 

I have looked at the trance and it appears to be the problem I described to you
in a private email about 5 days ago:

From: Damien Elmes <resolve at>
Subject: Re: Getting a BJC2100SP to work
To: Richard Rose <richard58 at>
X-Sent: 5 days, 17 hours, 25 minutes, 47 seconds ago

> That's what I used to try and set it up. It appears to recognise the printer 
> but when I restart the LPD and try to send a test page, nothing seems to 
> happen. I checked lpq and can see that it is trying to send something to the 
> printer but it quits after 3 attempts.

I encountered this problem at work, and spent a few hours debugging it. We were
using a BJC6000. The printer config basically consists of a list of options to
either pass to "gs" on the command line, or to pass to it via a pipe. For some
reason one of the options was being twiddled and arriving via the pipe, which
caused GS to throw up an error.

Hunt down /var/spool/printername/printername.status # i think that's it

for more detailed output on what's going wrong. I solved the problem by hacking
one of the perl scripts in the printconf distribution to explicitly insert that
option on the command line, and explicitly drop it if trying to send through
the pipe. Really ugly fix, but I didn't have time to chase up the root cause of
the problem (the printer definition file had the arg correctly identified)


You'll notice in your trace output from the first file that there's a message
saying "Printer model must be specified with -sModel". That's the command which
is going to the wrong place.


Damien Elmes
resolve at

More information about the linux mailing list