NIS + automount fiddling

Richard Cottrill richard_c at
Tue Sep 4 04:19:48 EST 2001

Hello everybody,

I've got a bit of an issue with NIS and automounting. Today I actually sat
back and figured out roughly how to get NIS working. I can now use the
central user/password store in my (office) network to authenticate users.
I'm quite happy with that. I'm still not too sure if it's a NIS or NIS+
system but it's running anyway.

What I'd like to do now is get to my files. When I login I get thrown to
$HOME=/ This makes it a bit hard to see my files.

The machine I'm trying to set up is crius, a RH6.2 machine. The NIS(+)
map/database is good (works for our Solaris 6/7/8 and HP 11 boxes) and now
I'm trying to extend the system to our Linux boxes. I didn't set up the
others and I'm a total newbie in the NIS/automount field.

I suspect that the NIS bit is working ok and that the various information is
being found and accessed just fine. The problem for me is integrating the
NIS(+) information with autofs/automount.

I'm hoping to have a directory structure that looks like:
/home				<--- a real directory
	/richard		<--- normal, local account, normal directory
	/david		<--- as above
	/jeremy		<--- some NIS user with automatically mounted NFS $HOME
	/somebody-else	<--- another NIS user

My questions to the wise among us:
* How do I figure out if I'm using NIS or NIS+ (I've tried both 'yp' and
'nisplus' in the auto.master file to no avail - yes I reload between
* what strange combination of yp* commands can I use to see what's being
returned from the NIS server to autofs (assuming autofs is making the query
in the first place)?
* Would having more than one person logged in at a time result in a 'mount
tree' (more than one file system to be mounted under a specific automount
point - from autofs(5)) described as unsupported in the autofs(5) page?
* Is this set up possible for Linux, and if so, how?
* My next victim for this treatment is a Red Hat 7.1 box; will there be any
changes for the procedure there?

Thanks guys,



Various factoids:
* crius is using the standard/static $HOME dirs for local accounts at
/home/<user name>
* pikachu is a Solaris 7 machine and everything is running fine; my NIS
login works OK on there.
* the NIS server is on a different machine again, on a different subnet to
both (pikachu + crius) computers.
* The user I'm logging in with doesn't exist as a user on crius; only in the
NIS system.
* I can normally log in to as many different machines as many times as I
like without hitting any kind of limit.

The versions I'm playing with:
[root at crius /root]# automount --version
Linux automount version 3.1.4
[root at crius /root]# ypbind --version
ypbind (ypbind-mt) 1.7

crius' (broken?) /etc/auto.master file
# $Id: auto.master,v 1.2 1997/10/06 21:52:03 hpa Exp $
# Sample auto.master file
# Format of this file:
# mountpoint map options
# For details of the format look at autofs(8).
#/misc  /etc/auto.misc  --timeout 60
/home   yp:auto_home       -nobrowse

pikachu's (working - Solaris) /etc/auto_master file:
# Master map for automounter
/net            -hosts          -nosuid,nobrowse
/home           auto_home       -nobrowse
/xfn            -xfn

The output when I try to log in to crius:
<user name>@pikachu# telnet
Connected to
Escape character is '^]'.

Red Hat Linux release 6.2 (Zoot)
Kernel 2.2.19-6.2.7 on an i686
login: <user name>
Last login: Mon Sep  3 17:49:44 from
This is crius... Please enjoy your stay.			<--- MOTD
Or don't. It's not as if I care.
No directory /home/<user name>!
Logging in with home = "/".

More information about the linux mailing list