Fun with lp

Antti.Roppola at Antti.Roppola at
Tue Aug 21 12:12:28 EST 2001

Hello all,

Can anyone offer suggestions on what to look at next in
getting my Gestetner postscript laser printer (much the
same as an Apple LaserwriterII) to work?

The box dual boots and it prints OK in Windows. Installing
the printer took some effort as I had to tell Windows _not_
to use bidirectional parallel ports and such. From memory,
the port is set to SPP in BIOS.

According to Windows the parallel port is at 0378 IRQ7.

Under Linux, I have tried a number of things in conf.modules,
mostly looking like permutations of:
	alias parport_lowlevel parport_pc	# was already there.
	options lp io=0x378 irq=7		# tried a few things

Then variously modprobe, insmod & modconf to load the module.
The above setting seems to be acceptable, but when I dump text
to the device, the printer blinks lights for a long while and
nothing else happens.

daria:/etc# echo "foo" > /dev/lp1
daria:/etc# echo "foo" > /dev/lp0

More information about the linux mailing list