nis login problem solved

Johnrob Bantang geekborj at
Wed Jan 26 07:38:39 GMT 2005

Hello to Francisk at

In case you haven't solved your problem with nis yet..

I had the same problem with my setup. apparently, the
problem is in your firewall.  Theoretically, you
1) remove all the firewall
2) specify port number of your ypbind/ypserv services
and allow that through your firewall.

now, i could have results with #ypcat hosts and
#ypmatch <username> passwd.



=================pasted message=================

1) Install redhat 8
2) login as root user
3) create a usergroup called student
/usr/sbin/groupadd student
4) create users and add users to the "student" group
#/ usr/sbin/adduser joe
#  passwd
add joe, jane and tom into student group
#  gpsswd - joe student
#  gpsswd - jane student
#  gpsswd - tom student

5) define nis domainname in network file
at /etc/init.d/network :
#set the nis domain name

5-1) create /etc/auto.home
franck amish:/export/home/&
jane amish:/export/home/&

5-2) update /etc/auto.master
/home yp:auto.home	--timeout=60

6) setup /etc/yp.conf
domain server amish

7) at /etc/hosts include nis ver ip address in hosts
192.168.xx.xx amish
ypserver amish

8) configure NIS client deamon
chkconfig ypbind on

9) modify /var/yp/Makefile

10) Define NIS client access in /var/yp/securenets

allow local host connection
host 192.168.76.x

allow client workstation to access

11) build nis map files
ypinit -m

12) start ypserv and ypbind
/etc/rc.d/init.d/ypserv start
/etc/rc.d/init.d/ypbind start

13) I can see the hosts file but some hosts are
duplicate when I do 
"ypcat hosts"

14) check that I can match a map entry - ypmatch jane

15) change nisplus to nis in all /etc/nsswitch.conf

passwd: 	files nis
shadow:	files nis
group:		files nis

hosts:	files nis
ethers:	files
netmasks:	files
networks:	files
protocols:	files
rpc:	files
services:	files
bootparams:	files

netgroup:	nis
automount:	files nis

16) start ypserv and ypbind
/etc/rc.d/init.d/ypserv start
/etc/rc.d/init.d/ypbind start

17) check auto home works
/etc/rc.d/init.d/autofs restart

18) restart naming services

19) reboot

At NIS Client
1) /etc/init.d/network
domainname trident

domain server amish

3)chkconfig ypbind on

4) reboot

5) Checking nis is working
# ypwhich

6) check map is sharing
# ypcat hosts

Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now

More information about the linux-nisplus mailing list