linux-nisplus digest, Vol 1 #162 - 3 msgs

Doug Fajardo dfajardo at
Sat Oct 26 10:27:05 EST 2002

YES. (Or at least this is one source for it).
    Here's the scoop...

    The gmp package considers mp.* to be a 'Berkley MP compatibility
When the source is compiled, there is an extra flag on configure which is
necessary to build the library "--enable-mpbsd".

     Different RPM binaries may - or may not - have these files built as
part of the
package. I recomend compiling/installing the gmp package from source
The configure line that I used was (cavet emptor!):

      ./configure --prefix=/usr --enable-mpbsd

Good Luck!

-----Original Message-----
From: linux-nisplus-admin at
[mailto:linux-nisplus-admin at]On Behalf Of
linux-nisplus-request at
Sent: Friday, October 25, 2002 9:00 AM
To: linux-nisplus at
Subject: linux-nisplus digest, Vol 1 #162 - 3 msgs

Send linux-nisplus mailing list submissions to
	linux-nisplus at

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
	linux-nisplus-request at

You can reach the person managing the list at
	linux-nisplus-admin at

When replying, please edit your Subject line so it is more specific
than "Re: Contents of linux-nisplus digest..."

Today's Topics:

   1. nis-utils and mandrake (mm6)
   2. Re: Almost there, but a few problems (Robert Edwards)
   3. Re: nis-utils and mandrake (Gabriel Kihlman)


Message: 1
Date: Thu, 24 Oct 2002 15:00:27 -0300
Subject: nis-utils and mandrake
From: "mm6" <mm6 at>
To: linux-nisplus at


I tried to install nis-utils in a pc
with mandrake linux 9.0 and I had many
Someone I have already resolved but
now this is the problem:

make[3]: Entering directory
/bin/sh ../../libtool --mode=3Dlink gcc
 -W -Wall -Wbad-function-cast
-Wcast-align -Wcast-qual -Winline
-Wmissing-prototypes -Wnested-externs
-Wshadow -Wstrict-prototypes -Wundef
-g -O2  -o chkey  chkey.o -lnsl

../../lib/compat/libcompat.a -lmp
gcc -W -Wall -Wbad-function-cast
-Wcast-align -Wcast-qual -Winline
-Wmissing-prototypes -Wnested-externs
-Wshadow -Wstrict-prototypes -Wundef
-g -O2 -o chkey chkey.o -lnsl -lcrypt
../../lib/compat/libcompat.a -lmp
/usr/bin/ld: cannot find -lmp

Does anyone know about that?
Is mp the gmp?

Thanks in advance,


BOL - tr=EAs anos com voc=EA. Venha pra festa e ganhe uma viagem!
Ainda n=E3o tem AcessoBOL? Assine j=E1!


Message: 2
From: Robert Edwards <bob at>
To: Bruce Baumgart <baumgaba at>, linux-nisplus at
Subject: Re: Almost there, but a few problems
Date: Fri, 25 Oct 2002 10:20:36 +1000

On Thu, 24 Oct 2002 02:53, Bruce Baumgart wrote:
> Standard boiler plate:  Help!!!
> Trying to add Redhat 7.3 client to an existing Solaris 8 NIS+ domain.  I
> so close that I can see it, but a couple of problems that may even be
> related.
> Existing setup, names munged to keep security happy.
> Domain -
> Sub-domain -
> Server - Solaris 8
> Client - Redhat 7.3 workstation install, gnome brought up at connect.
> Trying to add machine to sub-domain.
> Sub-domain server is my ntpd server.
> I am following Marc Wrubleski's cookbook, with the following exceptions:
> When I tried doing the nisinit -c -H <host>, got the infamous
> not served by this server
> message.  So I copied a cold start file from a working Solaris box and did
> a nisinit -c -C <filename>.  That worked, as did the keylogin.  Left all
> the PAM stuff alone, figuring that if it was OK in Redhat 7.2, it should
> OK in 7.3.  After a reboot; domainname and nisdomainname are right;
> and autofs are running.  I am logged on as root, so nisdefaults shows the
> client box as the principal, and it is authenticated.  A niscat works.
> Now the problems.
> A "nisls" works.  No other nisls command does.  They all fail
> not served......
> I try to log on with my working-on-Solaris-machines userid.  I get logged
> on and my home directory mounted.  Because it is a very Solaris-specific
> logon profile, a bunch of mounts don't work, and the PATH is really really
> broken.  I built a .bashrc that corrects the path, and everything dealing
> with the client box seems to work.  However, a nisdefaults shows my id as
> the principle, and not authenticated.  niscat works, nisls doesn't.
> I have scoured the archive file.  Not much there.  Next question - Is
> a searchable archive online somewhere?
> TIA, especially if you made it this far.......

If nisdefaults is returning "not authenticated", then you won't be able to
read the passwords map and hence not login. You need to create a credential
for your NIS+ client on the server using some random secure password. You
then need to run chkey -p on your NIS+ client, giving it the same password,
followed by your root password. If the time on your client are close enough
to the time on your server (use NTP), then you should not be seeing "not
authenticated" in nisdefaults.


Bob Edwards.


Message: 3
To: "mm6" <mm6 at>
Cc: linux-nisplus at
Subject: Re: nis-utils and mandrake
From: Gabriel Kihlman <gk at>
Date: Fri, 25 Oct 2002 08:59:08 +0200

"mm6" <mm6 at> writes:

> Hi,
> I tried to install nis-utils in a pc
> with mandrake linux 9.0 and I had many
> problems.
[ .. ]
> ../../lib/key_common/libkey_common.a
> ../../lib/compat/libcompat.a -lmp
> /usr/bin/ld: cannot find -lmp
> Does anyone know about that?
> Is mp the gmp?

I pulled down gmp-4.1 and did
./configure --enable-mpbsd --prefix=/usr; make; make install
Now it works fine.


linux-nisplus mailing list
linux-nisplus at

End of linux-nisplus Digest

More information about the linux-nisplus mailing list