[linux-cifs-client] [PATCH 0/4] cifs: clean up cifs_unlink and fix silly-renames

Jeff Layton jlayton at redhat.com
Tue Sep 16 11:27:12 GMT 2008


This patchset is a cleanup of the cifs_unlink() code. It moves most of
the "silly-rename" logic into a helper function and has cifs_unlink call
it. It also fixes the silly-rename logic, which didn't work quite right
in some cases and also adds a new function to properly set the
DELETE_ON_CLOSE bit on files that already exist. With this patchset,
CIFS VFS can now pass the op_chmod test in the Connectathon test suite
when tested against a win2k3 server.

The patchset is a little larger than the resulting code. I attempted to
preserve bisectability with it, so I suggest applying them in order. If
everything looks OK, this patchset is probably appropriate for 2.6.28.

Jeff Layton (4):
  cifs: clean up variables in cifs_unlink
  cifs: use common code for turning off ATTR_READONLY in cifs_unlink
  cifs: move silly-rename logic into helper function
  cifs: add function to set file disposition

 fs/cifs/cifsproto.h |    2 +
 fs/cifs/cifssmb.c   |   55 +++++++++++++
 fs/cifs/inode.c     |  220 ++++++++++++++++++++++++++-------------------------
 3 files changed, 168 insertions(+), 109 deletions(-)



More information about the linux-cifs-client mailing list