[linux-cifs-client] Re: mount.cifs returns Input/output error fedora core 3 to window server 2003

Warren Roberts warren at roberts.name
Mon Jan 10 19:31:41 GMT 2005

Sjoiks!!!  I finally go my mount command to work.  I thought I would post
my results in the hope that it will help anyone else out there that runs
into the same problem.

Unbelievably the problem was that the name in my hosts file on linux
didn't match the name that I gave the windows server box.  It will not
mount with an ip address or if the hostname's differ.  This must be some
sort of strange windows security fix.

> I am trying to get a cifs mount from fedora core 3 to my new Windows 2003
> Server.  I've tried to mount it from both fedora core 3 and fedora core 2
> but they both give the same error.
> mount -t cifs -o user=foo //wcam/wTerra2 /mnt/wTerra2
> Password:
> mount error 5 = Input/output error
> Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
> If I try
> mount -t smbfs -o user=foo //wcam/wTerra2 /mnt/wTerra2
> it works fine so I know the mount point permissions are ok on the windows
> box.
>>From the linux systems I can mount share points using "-t cifs" on my
> windows xp laptop just fine as well.
> Does anyone have an idea what is wrong.  I've googled around for several
> hours but found no answers.
> Thanx
> Warren Roberts

More information about the linux-cifs-client mailing list