[jcifs] Getting parameter is incorrect error message in jcifs-1.3.17

André Warnier aw at ice-sa.com
Mon Apr 20 06:54:40 MDT 2015


Please read the 1st paragraph, marked "IMPORTANT", in blue letters.

Dharini pasupathy wrote:
> Hi Team,
> My application uses the domain controller of version 2003 for *single
> sign-on (sso)* and it is now upgraded to version 2008. Before up-gradation,
> I used *jcifs-1.3.14* library and it was perfectly working fine for *sso*.
> Now after up-gradation I'm facing compatibility issues with the jcifs
> library (jcifs-1.3.14) and the domain controller verison (2008). So,I tried
> with *jcifs-1.3.17 and jcifs-1.3.18* jars. I'm getting "*the parameter is
> incorrect*" error message during sso. Also I'm using ntlmv2 for
> authentication and I dont find any issues with the authentication.
> I tried with different jcifs.smb properties to resolve the issue.The
> properties which i tried are mentioned below :
> "jcifs.smb.lmCompatibility" = "", (values ranges from 0 to 5)
> "jcifs.smb.client.useExtendedSecurity" = "", (either true/false)
> I tried with all the possible combinations. But no luck yet.Can anyone
> please help me to resolve my issue ....

More information about the jCIFS mailing list