[jcifs] NTLM POST failing against SharePoint

Sean Cooper secooper at mitre.org
Fri Oct 31 19:37:45 GMT 2008

I am trying to call a SharePoint webservice using the JCIS package.  The 
message that I am getting back from SharePoint is HTTP 400 "Bad Request 
(Invalid Verb)" which I believe means that the SOAP message did not get sent.

I loaded up Wireshark to take a look at the traffic to the SharePoint 
installation.  It is sending the initial POST and receiving the authentication 
denied message.  After a few trips I believe the authentication is working, but 
on the final trip back to the SharePoint server it is only sending the HTTP 
headers.  So on the final trip back there is no attached POST information to 
execute the SOAP.  I tried using Apache's HttpClient package and I also opened 
up a NtlmHttpConnection and simply wrote the SOAP POST, and both of them 
returned the same error message from SharePoint.  Is SharePoint not handling 
the NTLM handshake with the POST data correctly?  Could something be tweaked on 
the JCIFS package to force the POST data to resend during the last trip back to 
the server?


More information about the jcifs mailing list