[jcifs] Running NTLMServlet on a UNIX box - Domain gets confused.

Thomas Campbell thomas.harold.campbell at gmail.com
Fri Nov 16 18:58:25 GMT 2007


I'm sure this has been asked before but I've found the archives but not sure
where the search function for them is.  I've been looking via Google but..
well anyway..

Here's my problem:

I'm using NtlmServlet inside of Tomcat 5.5.23.  It works great when I run
the server on Windows however, when I run the server on UNIX it doesn't.
The problem is that it's not getting the domain correctly.

When I run th server on Windows, it usually logs the client browser in
seamlessly.  No problems.  On UNIX, usually the authentication box pops up.
Now that's ok if it does that but it prepopulates the username with the
hostname instead of the domain name.  And well, my users just aren't that
smart.  It'll confuse them.  How can I make it stop doing that?

I've set jcifs.smb.client.domain to the domain name but it ignores it
completely.  I even tried hacking the code and forcing it to use the correct
domain name but that fails as well.

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the jcifs mailing list