[jcifs] NTLM Authentication problem

Manikandan Chandrasekaran mani.chandrasekaran at gmail.com
Wed Sep 13 09:20:42 GMT 2006

I have attached the log for that error. Hope this may help in finding out
the problem.

NtlmHttpFilter: <HOSTNAME>\manikandanc: 0xC0000022:
jcifs.smb.SmbAuthException: Access is denied.
treeConnect: unc=\\<DOMAIN CONTROLLER>\IPC$,service=?????
New data read: Transport1[DOMAIN CONTROLLER<20>/]
00000: FF 53 4D 42 73 22 00 00 C0 98 07 C0 00 00 30 5F  |ÿSMBs"..Ã..Ã..0_|
00010: 25 6E B2 70 DD A5 00 00 00 00 90 B2 00 00 16 00  |%n²pÃ


---------- Forwarded message ----------
From: Manikandan Chandrasekaran <mani.chandrasekaran at gmail.com>
Date: Sep 12, 2006 5:57 PM
Subject: NTLM Authentication problem
To: jcifs at lists.samba.org

    I am using jcifs for doing NTLM Authentication using tomcat. Let me
explain the scenario for you to understand:

I tried to login using NTLM authentication. It went through fine. Then I
asked my friend to login. When he tried, he could not login. Then we
restarted the server. Then I asked him to login. Now he could login but not
me. ie. It seems like only one user can be logged in. We didn't understand
what could be wrong.

Am I missing something?
Can you please tell me what is causing the problem?

The following is the configuration I added in my web.xml

         <param-value>DOMAIN CONTROLLER</param-value>
        <param-value>MY HOST NAME</param-value>


-------------- next part --------------
HTML attachment scrubbed and removed

More information about the jcifs mailing list