[jcifs] Problem reading files from a share

Ingo Rockel irockel at pironet-ndh.com
Thu Oct 26 12:44:49 GMT 2006

Hi all,

we recently switched to j2sdk1.4.2_12 and there we have a Problem 
fetching contents of a share using jcifs. The problem doesn't exists in 
j2sdk1.4.2_11 nor in jdk1.5.0_08 nor recent RC of 1.6.

I've attached a small test class demonstrating the problem. The class 
tries to connect to a share passed as param (something like 
"smb://user:pw@some.machine/some_share/") and lists the content. With 
all jdks except 1.4.2_12 the result is ok, but with 1.4.2_12 something 
like this is returned:

****** loop files
****** smb://x:x@some.server/webdav_test/?/
****** smb://x:x@some.server/webdav_test/??/
****** smb://x:x@some.server/webdav_test/???????????????
****** smb://x:x@some.server/webdav_test/????????????/
****** smb://x:x@some.server/webdav_test/??/
****** smb://x:x@some.server/webdav_test/??????????
****** smb://x:x@some.server/webdav_test/???????????????

I tried connections to (german) win2000 and win2003 server, both return 
the result above. If connecting to a smb-server running on linux the 
result is ok. I tried setting jcifs.encoding to different values 
(cp1252, utf8) but without any success.

I checked the release notes of 1.4.2_12 but anything of the changes 
looks like it affects this.

Any Ideas?


Dipl. Inf. Ingo Rockel - Produktentwicklung
Maarweg 149-161, 50825 Koeln
Tel.: +49 (0)221-770-1788 / Fax: +49 (0)221-770-1005
mailto:irockel at pironet-ndh.com - http://www.pironet-ndh.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: JCifsTest1.java
Type: text/x-java
Size: 1777 bytes
Desc: not available
Url : http://lists.samba.org/archive/jcifs/attachments/20061026/44742e99/JCifsTest1.bin

More information about the jcifs mailing list