[jcifs] RE: Major minor version error in JCIFS1.2.8

gruizf at credomatic.com gruizf at credomatic.com
Thu Mar 30 14:38:35 GMT 2006

Thanks David but deleting all my class files didn't work. I believe I
should change some compiler settings but... what compiler settings should I
change, and where in Websphere?

If I put jcifs1.2.8.jar in the lib directory, the below error occurs. If I
switch back and put jcifs1.2.7.jar in the lib directory, then the error
goes away.

             "David Sprowls"                                               
             <ctasprowls at fastm                                             
             ail.fm>                                                    To 
             Sent by:                  jcifs at lists.samba.org               
             jcifs-bounces+gru                                          cc 
             m at lists.samba.org                                     Subject 
                                       [jcifs] RE: Major minor version     
                                       error in JCIFS1.2.8                 
             29/03/2006 06:16                                              

I don't think this is a jcifs issue.  I am able to use NtlmHttpFilter
with jre1.4.x.

I have run into this problem with other java code before in Eclipse.  It
was always because I some problem with my compiler settings that Eclipse
was using or I had switched them and had only compiled part of my code
with the new compiler settings.  Delete all of your class files and

Hopefully that helps.

From: <gruizf <at> credomatic.com>
Subject: Major minor version error in JCIFS1.2.8
Newsgroups: gmane.network.samba.java
Date: 2006-03-29 17:16:00 GMT (6 hours and 49 minutes ago)


I am using JCIFS1.2.7. It's important for me to eliminate the Deadlock
issue, so I switched to 1.2.8.

I am getting this error:
[Error de servlet]-[Filter [NtlmHttpFilter]: could not be loaded]:
java.lang.LinkageError: LinkageError while defining class:
Could not be defined due to: jcifs/http/NtlmHttpFilter (Unsupported
major.minor version 49.0)

I'm using WAS5.1.2. I already switched Java compiler from 1.3 to 1.4 but
still get the same error.

What else could I do?


  David Sprowls
  ctasprowls at fastmail.fm

More information about the jcifs mailing list