[jcifs] Every 2nd Connection fails

Michael B Allen mba2000 at ioplex.com
Wed Jan 25 17:36:27 GMT 2006

On Wed, 25 Jan 2006 12:18:48 +0000 (UTC)
nicholas new <new at mdw.ac.at> wrote:

> Hallo everybody!
> I am new to jcifs but have managed to get it to work. I am using it to connect 
> to a Windows 2003 Server from a PL-SQL programme running in an Oracle database,
> in order to download and view a PDF file.
> Every 2nd time I run the Programm I get the error message below. 
> I have tried connecting to another Windows machine and have also run the 
> programme itself on a different machine (both Solaris).
> The behaviour was the same.
> If I make and close the connection twice in the Java part of the programme 
> there is no error. So I am very perplexed.
> Any ideas would be most welcome! 
> jcifs version: jcifs-1.2.7.jar
> java version on the DB: 1.3.1
> Thanks a lot!
> Best Wishes
> Nicholas New
> jcifs.smb.SmbException: 
> jcifs.util.transport.TransportException: Transport1 timedout waiting for 
> response to SmbComNTCreateAndX
> [command=SMB_COM_NT_CREATE_ANDX,received=false,errorCode=0,flags=0x0018,flags2=
> 0xC007,signSeq=318,tid=53250,pid=39867,uid=47105,mid=1449,wordCount=24,by
> teCount=35,andxCommand=0xFF,andxOffset=0,flags=0x00,rootDirectoryFid=0,desiredA
> ccess=0x0089,allocationSize=0,extFileAttributes=0x0080,shareAccess=0x0007,creat
> eDisposition=0x0001,createOptions=0x00000040,impersonationLevel=0x0002,security
> Flags=0x03,name=\1
> \D\0000D1.ados]
>   at jcifs.util.transport.Transport.sendrecv(Transport.java:74)

Try one of the examples like examples/Get.java. Use all stock properties
and the Sun JVM. If that works then you should be able to narrow down
through trial and error what the cause is.

If that doesn't work, something is very odd. Post back here what the
error is.


More information about the jcifs mailing list