[jcifs] NT_STATUS_UNSUCCESSFUL Exception under heavy load

Michael B Allen mba2000 at ioplex.com
Fri Oct 28 02:20:48 GMT 2005

On Thu, 27 Oct 2005 17:25:13 -0700
Praveen Tammana <praveen.public at gmail.com> wrote:

> Reviving an old thread...
> I am also seeing this error sporadically. It works fine for a while. Then I
> see a few (< 10) of these errors in a row and then it works fine again for
> some more time. (My app is a server to which I send read dir and read file
> requests). I just caught it happening a while ago while trying to read a
> file. I then sent a read-dir request (uses SmbFile.listFiles()) to my server
> for the directory containing this file and it worked fine. I then sent a
> read-file request for the same file and got the same error again. I repeated
> this sequence of readDir-readFile a few times with the same result - readDir
> worked every time but reading file failed every time with this error.
> jcifs.smb.SmbException: A device attached to the system is not functioning.
> at jcifs.smb.SmbTransport.checkStatus(SmbTransport.java:453)
> at jcifs.smb.SmbTransport.send(SmbTransport.java:553)
> at jcifs.smb.SmbSession.send(SmbSession.java:226)
> at jcifs.smb.SmbTree.send(SmbTree.java:95)
> at jcifs.smb.SmbFile.send(SmbFile.java:688)
> at jcifs.smb.SmbFile.open0(SmbFile.java:827)
> at jcifs.smb.SmbFile.open(SmbFile.java:845)
> at jcifs.smb.SmbFileInputStream.<init>(SmbFileInputStream.java:69)
> at jcifs.smb.SmbFileInputStream.<init>(SmbFileInputStream.java:62)
> I then restarted my jCIFS server and sent the same sequence of requests and
> they both worked fine. ~15 minutes later, I again started to see the same
> error sporadically.
> I am not exactly doing multi-threading here. Let me clarify. My app is
> multi-threaded but the lone entry point into jCIFS is synchronized. I did
> this because I was getting a lot of (the same, I think) errors when I tried
> it without synchronization earlier. The load is high, i.e., there is always
> a request pending.
> jCIFS version - 1.2.1
> client : linux
> file servers : A couple of Win XP Pro machines

Try the latest jar. It should be totally compatible with 1.2.1 and we've
been doing only stability fixes.  Also, crank up XP auditing and look
at the eventlog.


More information about the jcifs mailing list