[jcifs] Re: Can't authenticate with newer samba

Need Coffee need.coffee at gmail.com
Wed Jun 8 15:46:44 GMT 2005

Apologies for spamming the list.  For some reason although I am subscribed 
to it, and my options say I should receive my own posts, I never did.  I just 
checked the archives and saw my posts... sorry.

Did anyone have an issue upgrading from samba 2.2.x to samba 3 when
using davenport or jcifs?

This is with encrypt passwords = no in samba, btw...

>From watching packets it looks like jcifs is using the lowest smb protocol
dialect (0) even though I've specified higher.  And even setting "min protocol"
in smb.conf hasn't helped.  Any ideas welcome... thanks in advance.

On 6/8/05, Need Coffee <need.coffee at gmail.com> wrote:
> Hello,
> I am using Davenport 0.9.10 with its bundled jcifs-0.9.7 just fine
> with samba 2.2.x.
> Unfortunately, upgrading samba to 3.0.14a causes authentication to fail
> from Davenport, even though PCs can still authenticate fine.
> In looking at what's on the wire, it looks like a problem with the NTLM auth
> level.  Downgrading samba back to 2.2.x allows logins to work just fine again.
> I ran both versions off the same smb.conf.
> I've tried updating jcifs to several recent versions, and tried a few
> older releases of samba (3.0.11 leaps to mind) all without success.  I also
> tried tweaking various things in smb.conf as well as Davenport's web.xml
> (one at a time, of course ;) without any success.
> I assume some default has changed in samba, which then requires either a
> config or code change in Davenport or jcifs, but I'm having a bit of trouble
> determining what is at work.
> Any help is appreciated, thanks in advance.

More information about the jcifs mailing list