[jcifs] NtlmHttpFilter ERRSRV/89

Scovetta, Michael V Michael.Scovetta at ca.com
Fri Mar 5 15:29:17 GMT 2004

I posted this not too long ago, but I don't think I specified that it 
had to do with the NtlmHttpFilter--
I'm getting this
jcifs.smb.SmbException: No description available [ERRSRV/89]
        at jcifs.smb.SmbTransport.send(SmbTransport.java:771)
        at jcifs.smb.SmbSession.sessionSetup(SmbSession.java:140)
        at jcifs.smb.SmbSession.send(SmbSession.java:103)
        at jcifs.smb.SmbTree.treeConnect(SmbTree.java:132)
        at jcifs.smb.SmbSession.logon(SmbSession.java:56)
        at jcifs.http.NtlmHttpFilter.doFilter(NtlmHttpFilter.java:130)

sporadically-- It only seems to occur when the load on the server is over
50 sessions-- still not very high. The filter seems to be fine for a while,
then everyone gets this exception. If I pass them to another server, they
don't get the exception, but the load is less on the other server.

>From both, I'm using the same filter settings.

I've tried this one first:
  <filter-name>NTLM HTTP Authentication Filter</filter-name>

I also tried replacing the domainController param
by loadBalance (true), but that didn't help.

Could active-directory be an issue here? I'm not concerned
about domain groups or the such-- I just want to verify that
the user's name/pw is correct.

If anyone can give me some insight, it'd be a big help.

Michael Scovetta

More information about the jcifs mailing list