[jcifs] RE: Davenport - Copy Operation Uses Many Ports?

Mike McDonald Mike.McDonald at anywaregroup.com
Thu Jun 10 17:03:31 GMT 2004

Sorry, forgot to copy the group.

-----Original Message-----
From: Mike McDonald [mailto:Mike.McDonald at anywaregroup.com] 
Sent: Thursday, June 10, 2004 2:03 PM
To: 'eglass1 at comcast.net'
Subject: RE: Davenport - Copy Operation Uses Many Ports?

I tried it using Basic authentication.  I noticed a few things.  Bear
with me as I try to explain.

I did not have a lot of luck with Basic authentication.  It was kind of
hit or miss whether it authenticated properly.  For example, I would
enter a URL such as http://davserver/davenport/fileserver/share and it
would prompt me for credentials.  When I entered the username and
password it displayed the list of folders/files properly.  If I
attempted to copy one of those folders however, it would prompt for
credentials again, and behave as if I entered incorrect credentials
(i.e. three tries then blank screen).

At this point, I stopped the Davenport servlet and restarted it without
closing my IE client.  I again tried to copy the same folder, and was
prompted for credentials.  I entered the credentials and the folder
copied properly.  It appears that only the initial authentication
attempt is successful.  All subsequent attempts fail.

In terms of the connections created, it appears that a new connection is
created for each authentication attempt.  New connections are not
created for file copy operations.  I could copy wide/deep directory
structures without a ton of connections being created. 

I also noticed that the client takes a very long time to 'Calculate the
time required to copy files.'  Once it starts copying, it is fairly
fast, but it does sit at this popup for a while (20 seconds or so, when
copying a hierarchy of empty directories).

Thanks again,


PS - I'll try rebuilding Davenport with the new Libraries.

-----Original Message-----
From: eglass1 at comcast.net [mailto:eglass1 at comcast.net] 
Sent: Thursday, June 10, 2004 11:19 AM
To: Mike McDonald
Cc: jcifs at lists.samba.org
Subject: RE: Davenport - Copy Operation Uses Many Ports?

> It is HTTP traffic between the client and the Davenport Server.  The
> attached netstat shows the connections made by simply copying a Folder
> containing 8 files from an SMB server to the client via Davenport
> running on Windows.  Interestingly enough, if I run Davenport on
> Solaris, the connections stay in an ESTABLISHED state.
> I took a look through a packet trace and the NTLM authentication
> handshake is in fact happening for each operation.  How can I force
> Basic Authentication in Davenport?  I set enableBasic=true and
> insecureBasic=true, but still get authenticated via NTLM.

You would want:

    jcifs.http.enableBasic = true
    jcifs.http.insecureBasic = true
    enableNtlm = false

> Also, I tried the jcifs0.9.2.jar, but Davenport does not appear to
> properly with it (setProperty errors?).  I only looked briefly, so I
> just have a misconfiguration.

I haven't tried (haven't had a chance to do much with Davenport lately).
Do you have a stack trace?


More information about the jcifs mailing list