[jcifs] copyTo mehod still not returning

Allen, Michael B (RSCH) Michael_B_Allen at ml.com
Tue Nov 5 15:30:20 EST 2002

> -----Original Message-----
> From:	Sujit Jagdev [SMTP:sujit.jagdev at casero.com]
> Sent:	Monday, November 04, 2002 6:03 PM
> To:	jcifs at lists.samba.org
> Subject:	[jcifs] copyTo mehod still not returning
> Michael,
> I just downloaded the latest jar file and tested it out.
> The scan is no longer deadlocked, which is great.
> However, the copyTo method is still deadlocking somewhere.
> If I try to create three or four SmbFile objects inside a for loop and
> invoke the copyTo method, the invocation never returns.
> I will send you a code sample to confirm.
	Please do. I just tried the attached code and I did not run into any
	deadlock. I'm not sure from your description how to reproduce the issue.
	Just curious, does wrapping copyTo with syncronized( lock ) like we
	discussed solve your problem?

	I did run into two other problems however I don't see how they could be the
	source of deadlock. One was getting "Access denied" if copying stuff on
	top of directories that already existed. Another was directories being
	created with names of files if a source file didn't exist. Both problems have
	been fixed; if a directory already exists the SmbAuthException is ignored
	and if a src file does not exist you will now get File not found or similar. I
	don't think I'll release a new beta right away. Here's a updated jar though:



More information about the jcifs mailing list