[jcifs] canRead always returning false

Michael B.Allen mballen at erols.com
Fri Dec 14 08:13:59 EST 2001

On Thu, 13 Dec 2001 12:41:23 -0800
Rob Wygand <rob at filefish.com> wrote:

> Mike,
> I'm basically only seeing wierdness in my app. Both your little test, 
> and a much larger test of my own devising (it's a command-line version 
> of our web-based product) always return the right results.
> So, it's either something very obscure that I'm hitting, or it's 
> something I'm doing wrong. I've had some people here do a quicl code 
> review of the stuff on top of jCIFS and it looks okay. So, I'm 
> confounded and confused.
> I've worked around this for now by not calling canRead(), so it's not a 
> giant issue. It's just weird.

Have you tried changing attrExpirationPeriod=0? It's entirely possible
there is some kind of weird crap going on under the hood. I haven't done
the full array of multi-threaded torture tests yet. I'm gearing up for
that though so we'll see RSN. If you can get a -Dlog=ALL of one of these
wierd canRead calls I'll take a look.


May The Source be with you.

More information about the jcifs mailing list