[distcc] I/O errors with distcc

Łukasz Tasz lukasz at tasz.eu
Fri Sep 5 05:32:33 MDT 2014


I got my answer :)
In my  case objects are really hudge, and compiles more than 60 secs,
distcc assumes that max lifetime is 60,
I fixed it manualy:
diff -rupN distcc-3.2rc2/src/mon.c distcc-3.2rc2_new/src/mon.c
--- distcc-3.2rc2/src/mon.c 2014-09-04 11:44:41.000000000 +0200
+++ distcc-3.2rc2_new/src/mon.c 2014-09-05 11:28:34.248008554 +0200
@@ -71,7 +71,7 @@
  * take a very long time, and combined with the check that the process
  * exists we can allow this to be reasonably large.
-const int dcc_phase_max_age = 60;
+const int dcc_phase_max_age = 300;


Łukasz Tasz

2014-09-05 9:12 GMT+02:00 Łukasz Tasz <lukasz at tasz.eu>:
> Hi Guys,
> does somebody has an idea what could be the issue that distccmon-*
> claimms that job is done on some node, but still client distcc process
> is waiting for something - mainly in select(...).
> This cause situation that few of many objects reaches IO timeout.
> Can I rely on distccmon-* tools?
> for a while I was thinking that mayby objects are
> compresssed/decompresed due tue ,lzo, tried to turn it off, but looks
> like with pump mode I cannot do it...
> Using latest distcc version 3.2.rc1,
> thanks for any suggestion
> Łukasz Tasz

More information about the distcc mailing list