[distcc] distcc-pump does not find system header files

Michael L. mlabbe at gmail.com
Sun Jan 19 20:39:37 MST 2014

I tried two separate code bases.  One could not find X11/Xlib.h (which is
installed on the computer running distcc-pump) and the other could not find
GL/gl.h.  These are system headers that, in my understanding, should be
transmitted to the remote distcc build host.

I start distcc-pump as follows:

eval `INCLUDE_SERVER_ARGS="--exact_analysis" distcc-pump --startup`
(Note I have tried without --exact_analysis as well)

And I compile with:

(Internally, this scons file uses CC=distcc CXX=distcc)

It is a C++ project.

distcc g++-4.7 <tons of build options omitted>


distcc[28829] ERROR: compile cl_draw.cpp on remotesrv,cpp,lzo failed
distcc[28829] (dcc_build_somewhere) Warning: remote compilation of
'cl_draw.cpp' failed, retrying locally
distcc[28829] (dcc_build_somewhere) Warning: failed to distribute and
fallbacks are disabled
In file included from /home/mlabbe/dev/include/Or/TextureSet.h:25:0,
                 from /home/mlabbe/dev/include/Or/Font.h:26,
                 from /home/mlabbe/dev/include/Or/DebugDraw.h:27,
                 from /home/mlabbe/dev/include/Or/DefaultSubsystems.h:28,
                 from local.h:26,
                 from cl_draw.cpp:23:
/home/mlabbe/dev/include/OrionRenderer.h:58:19: fatal error: GL/gl.h: No
such file or directory
compilation terminated.
scons: *** [cl_draw.o] Error 1

I am running:
distccd 3.1 x86_64-pc-linux-gnu
  (protocols 1, 2 and 3) (default port 3632)
  built May  9 2013 23:15:01

To me, this looks like the compile host is trying to look for system header
files locally.  The compile host definitely does not have GL/gl.h.

Much thanks.

Michael Labbe
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.samba.org/pipermail/distcc/attachments/20140119/93ee09b8/attachment.html>

More information about the distcc mailing list