[distcc] DistCC on Cygwin with FreeBSD Target?

Scott Spare scuppers at gmail.com
Sun Jan 22 18:28:32 GMT 2006

DistCC with Cygwin as the daemon and FreeBSD as the target (client):

-Compiling from the FreeBSD ports tree with distcc set as the compiler for
C, CXX, and CPP in /etc/make.conf, the distcc daemon's running on the cygwin

-Compile seems to fail due to "File format not recognized" errors.  For
example, this morning I tried running make install clean from
/usr/ports/games/flightgear...  The compilation doesn't complete.  Here are
my results:

if distcc -DHAVE_CONFIG_H -I. -I. -I../../simgear -I../..
 -I/usr/X11R6/include  -O2 -fno-strict-aliasing -pipe -march=pentium2 -MT
_values_test.o -MD -MP -MF ".deps/tabbed_values_test.Tpo" -c -o
st.o tabbed_values_test.cxx;  then mv -f ".deps/tabbed_values_test.Tpo"
abbed_values_test.Po"; else rm -f ".deps/tabbed_values_test.Tpo"; exit 1; fi
distcc  -O2 -fno-strict-aliasing -pipe -march=pentium2  -L/usr/local/lib
X11R6/lib -pthread  -o tabbed_value_test  tabbed_values_test.o
c/libsgmisc.a  ../../simgear/xml/libsgxml.a
tabbed_values_test.o: file not recognized: File format not recognized
distcc[66514] ERROR: compile (null) on localhost failed
*** Error code 1

Stop in /usr/ports/devel/simgear/work/SimGear-0.3.9/simgear/misc.
*** Error code 1

Stop in /usr/ports/devel/simgear/work/SimGear-0.3.9/simgear.
*** Error code 1

Stop in /usr/ports/devel/simgear/work/SimGear-0.3.9/simgear.
*** Error code 1
Also, I noticed it's at localhost, which maybe is because it's still doing
linking at this stage?
Confused about how to cross compile using Dan Kegel's scripts, but would
like to document it for the BSDs if I can get it working....

Using FreeBSD 6 Stable
GCC 3.4.4


On 1/21/06, Martin Pool <mbp at sourcefrog.net> wrote:
> On 20 Jan 2006, Scott Spare <scuppers at gmail.com> wrote:
> > Hello,
> > I wondered whether anyone has had luck running a DistCC server on Cygwin
> with
> > FreeBSD as a client / target.
> > I tried this, and it failed spectacularly - with errors about
> libraries...
> >
> > I would like to add some documentation to the FreeBSD port of DistCC on
> how to
> > get it working with FreeBSD as a target...  the BSd's seem to handle
> lib*.so
> > differently and I'd like to pass these targets correctly to the
> compiler.
> >
> > If anyone out there is a developer (or knows the guts) and would like to
> > collaborate on getting the right docs together and adding them to the
> port, I
> > can donate time for the writing.
> >
> > Mainly I am a tech writer and freebsd enthusiast who wants to see it
> work, but
> > I will contribute what I can if someone steers me in the right
> direction... :-)
> Any compile command that involves libraries is really a linker
> invocation and should be done locally on the client, without involving
> the server at all.
> Can you please post an example of a command that fails and the verbose
> distcc log for it?
> --
> Martin
> Version: GnuPG v1.4.1 (GNU/Linux)
> iD8DBQFD0rbAPGPKP6Cz6IsRAgwkAJ40AwMrPd47aY/Qpgy0kBciV/MocwCfRdJR
> MbIOsvqCdzmsmPjD3q0heD4=
> =QRD1
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the distcc mailing list